Rephrase service down

Incident Report for Sapling Intelligence

Resolved

This incident has been resolved.
Posted 10 months ago. Jun 18, 2024 - 21:55 UTC

Investigating

We have identified the issue and are resolving
Posted 10 months ago. Jun 18, 2024 - 21:15 UTC
This incident affected: API and Backend.