Increased multilingual usage leading to some timeouts

Incident Report for Sapling Intelligence

Postmortem

Increased load to multilingual handling as well as increased latency when sending Amplitude events led to degraded latency for other endpoints.

Posted Apr 30, 2025 - 05:39 UTC

Resolved

A fix has been implemented and we are monitoring the results.
Posted Apr 30, 2025 - 02:32 UTC